Pax8 Marketplace Down

Incident Report for Pax8 Platform

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 17:32 MDT

Monitoring

Restored: A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 16:26 MDT

Identified

We've identified the cause and are actively working on a fix for the issue impacting users' ability to access the Marketplace.
Posted Apr 23, 2026 - 15:53 MDT

Investigating

The Pax8 Marketplace is currently experiencing an outage affecting the ability to access it. Our team is actively working to restore service. We will provide an updates as we learn more. We apologize for the disruption.
Posted Apr 23, 2026 - 15:32 MDT
This incident affected: Pax8 Platform (Pax8 Platform, Login, Subscriptions).