NCE Tracker Outage
Incident Report for Pax8 Platform
Resolved
We've resolved an internal issue causing this outage. NCE Tracker is back!

Once again, apologies for any inconvenience this has caused.
Posted Aug 16, 2022 - 11:05 MDT
Investigating
We are currently experiencing an outage with NCE Tracker tool. We're investigating the issue and will provide updates to the status as we work diligently to resolve this issue.

We apologize for any inconvenience this has caused.
Posted Aug 16, 2022 - 10:24 MDT
This incident affected: Pax8 Platform (Microsoft Integrations).