We are continuing to monitor for any further issues.
Posted Jun 27, 2025 - 10:17 MDT
Update
Catalog data updates are completed. Our teams are monitoring the situation closely before marking the incident as 'Resolved'. Thank you for your continued patience — we’ll keep you informed.
Posted Jun 27, 2025 - 06:48 MDT
Update
Catalog Update – Data Refresh Delays
Catalog data updates are taking longer than expected. Our teams are monitoring the process closely and will provide updates as soon as full functionality is restored.
Thank you for your continued patience — we’ll keep you informed.
Over the next 2 hours, normal catalog functionality will be progressively restored. This will not occur all at once — but partners will begin to see expected behavior as data refreshes across the system.
We appreciate your patience as full updates propagate for all partners. A final confirmation will be shared once the rollout is complete.
Posted Jun 26, 2025 - 13:01 MDT
Identified
We are currently investigating degraded features in the platform impacting some users and some products, preventing certain products to be added to a shopping cart. We will continue to post updates here.
Posted Jun 26, 2025 - 02:59 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 12:53 MDT
Identified
We are currently investigating degraded features in the platform impacting some users and some products, preventing certain products to be added to a shopping cart. We will continue to post updates here.