Product Ordering Disruption

Incident Report for Pax8 Platform

Resolved

A fix has been implemented, and we are monitoring results.
Posted Mar 20, 2026 - 14:51 MDT

Identified

Some partners may be unable to select a client when placing orders for Partner Direct products. The issue has been identified, and our team is actively working on a fix. We will provide an update shortly.
Posted Mar 20, 2026 - 12:58 MDT
This incident affected: Pax8 Platform (Pax8 Platform, Orders).