Microsoft NCE Cancellation Date Issue
Incident Report for Pax8 Platform
Resolved
This incident has been resolved.
Posted May 06, 2022 - 08:25 MDT
Identified
When trying to cancel a Microsoft NCE subscription within the refund window, the cancelation date will default to and lock in on the anniversary date rather than allowing a same day cancellation. A fix for this issue will be released tomorrow (5/5). As a temporary workaround, affected partners who need to cancel immediately should navigate away from the impacted subscription, then navigate back to the impacted subscription and select their desired cancellation date.
Posted May 05, 2022 - 08:12 MDT
This incident affected: Pax8 Platform (Catalog).