Delayed provisioning of Microsoft orders and subscription renewals

Incident Report for Pax8 Platform

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 18:45 MDT

Update

We are seeing continued healthy performance across all systems and believe services have returned to pre-incident levels. Our teams will continue to monitor closely over the next few hours to ensure stability and consistent performance.
Posted Oct 29, 2025 - 17:17 MDT

Monitoring

A fix has been implemented and provisioning functionality is being restored. We are monitoring the results.
Posted Oct 29, 2025 - 16:08 MDT

Identified

We have isolated the issue to be related to a wider outage impacting multiple MSFT services globally. We will continue to monitor this issue and expect it to be resolved promptly, for more information please refer to MSFT's status page here: https://status.cloud.microsoft/
Posted Oct 29, 2025 - 13:35 MDT

Update

We are currently investigating an issue affecting Microsoft orders and subscriptions impacting all users. We will continue to post updates.
Posted Oct 29, 2025 - 11:14 MDT

Investigating

We are currently investigating delayed provisioning of Microsoft orders and subscription renewals impacting all users. We will continue to post updates here.
Posted Oct 29, 2025 - 10:58 MDT
This incident affected: Pax8 Platform (Pax8 Platform, Subscriptions).