Some users are experiencing errors logging into the Pax8 platform. If you experience login issues please wait a few moments and try again.
Incident Report for Pax8 Platform
Resolved
This incident has now been resolved.
Posted Dec 05, 2022 - 14:49 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2022 - 13:16 MST
This incident affected: Pax8 Platform (Login).