Catalog Not loading products
Incident Report for Pax8 Platform
Postmortem

Cause: The release for https://pax8.atlassian.net/browse/PSA-797 was moved up. It had in the original release to reset elasticsearch index. However that note wasn’t moved with it when it went out Tuesday instead of Thursday.

Future Plan: Catalog microservice will not rely on Elasticsearch index in Phase 2 slotted for March go live.

Now: Expose Catalog playbook for recovery to a broader audience to speed up recovery time

Identify alerting in ordering to push to Outage notification to alert sooner.

Devops to offer support on helping with alerting outcomes.

Posted Nov 16, 2022 - 08:54 MST

Resolved
Pax8 catalog experienced a brief outage where no products would load. This was caused by a new field added to the index in Elasticsearch. The fix was a reset of the index which brought the catalog back online within the next minute.
Posted Nov 15, 2022 - 19:00 MST