Subscription Modification Outage

Incident Report for Pax8 Platform

Resolved

This outage has been resolved.
Posted 1 year ago. Mar 21, 2024 - 16:28 MDT

Identified

We have identified an outage with Subscription Modifications. We are working diligently to resolve this issue quickly. Thank you for your patience. We will continue to update this status as progress is made.
Posted 1 year ago. Mar 21, 2024 - 14:58 MDT
This incident affected: Pax8 Platform (Subscriptions).