Corporate Pax8 Email System Impaired

Incident Report for Pax8 Platform

Resolved

This incident has been resolved.
Posted May 16, 2024 - 10:28 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 16, 2024 - 10:12 MDT

Investigating

Dear Partner,
This is a notification of a system issue affecting our ability to communicate with you through general email.

Pax8 is currently experiencing intermittent email system issues, and we are unable to send or receive emails normally. Our team is working to resolve the issue, but does not have an expected time of resolution yet. Please call Pax8 if you need assistance at this time.

Thank you for your patience and understanding during this time. We remain committed to restoring normal operation to our email system as soon as possible.

Thanks,
Pax8 alert
Posted May 16, 2024 - 08:41 MDT