P3 - Degraded Feature [Client Creation]

Incident Report for Pax8 Platform

Resolved

This incident has been resolved.
Posted Jun 28, 2024 - 08:42 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 28, 2024 - 07:37 MDT

Investigating

We are currently investigating a degraded feature preventing some users from creating new clients in the platform. We will continue to post updates here.
Posted Jun 28, 2024 - 07:06 MDT
This incident affected: Pax8 Platform (Pax8 Platform).