Watch Guard and Pro Serve Products cannot be purchased

Incident Report for Pax8 Platform

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 16:34 MDT

Monitoring

The issue affecting checkout for WatchGuard and Pax8 Professional Services products has been resolved. We believe all products should now be purchasable.
Posted Oct 10, 2025 - 11:56 MDT

Investigating

We’re aware of an issue affecting the ability to checkout Watch Guard and Pax8 Professional Services products. Our team is actively investigating the cause and working on a fix. We’ll provide an update as soon as more information is available.
Posted Oct 10, 2025 - 10:25 MDT
This incident affected: Pax8 Platform (Catalog).