Notification Delivery Delays

Incident Report for Pax8 Platform

Resolved

This is was resolved 9:02PM MT Thursday 4/2/2026.
Posted Apr 03, 2026 - 11:55 MDT

Identified

We are currently experiencing an issue that is delaying notification delivery by 3-5 hours, including Order Confirmations. Orders are processing normally.

If you are waiting on an Order Confirmation, you can verify your order status at https://app.pax8.com/ordering. Please do not resubmit orders, as they are being processed.

We are actively working to resolve the issue and will provide updates as they become available.
Posted Apr 01, 2026 - 12:43 MDT
This incident affected: Pax8 Platform (Pax8 Platform, Subscriptions, Orders).