User-Facing Delay in Data Refresh Across Application

Incident Report for Pax8 Platform

Resolved

We are back to normal behavior.
Posted Dec 02, 2025 - 14:52 MST

Monitoring

We’ve released a fix and are seeing significant performance improvements. Our teams will continue to monitor the system to ensure stability and full resolution.
Posted Dec 02, 2025 - 09:18 MST

Identified

We are aware of delays in updated information reaching the front end. Our teams are actively working to improve system performance and restore normal update times. We’ll share further updates as we make progress.
Posted Dec 02, 2025 - 07:27 MST
This incident affected: Pax8 Platform (Pax8 Platform, Catalog, Subscriptions).