Duplicate Order Processing

Incident Report for Pax8 Platform

Resolved

The issue has been resolved. Any affected orders will be corrected in the following days.
Posted Apr 01, 2024 - 20:32 MDT

Investigating

We have identified an order processing issue resulting in duplicate orders. Appropriate teams are actively working on a resolution. Thank you for your patience.
Posted Apr 01, 2024 - 19:11 MDT