Degraded feature: Pricing panel

Incident Report for Pax8 Platform

Resolved

This issue has been resolved.
Posted Jul 08, 2026 - 08:23 MDT

Identified

We are currently investigating a degraded feature (Pricing panel not showing pricing) in the platform impacting all partner users. We will continue to post updates here.
Posted Jul 08, 2026 - 03:30 MDT
This incident affected: Pax8 Platform (Catalog).