Pax8 Email Communication Impacted
Incident Report for Pax8 Platform
Resolved
This incident has been resolved. Any remaining affected emails will be resolved within the coming days.
Posted Jun 26, 2024 - 20:07 MDT
Update
Affected email communications are in the process of being resent. A further update will be posted once the process is complete.
Posted Jun 26, 2024 - 11:39 MDT
Update
We are continuing to work on resending affected communications.
Posted Jun 26, 2024 - 06:53 MDT
Monitoring
There was an issue preventing certain email communications from Pax8 being sent. Email communication has been restored as of 3:45 MT and the team is actively working on resending affected communications.
Posted Jun 25, 2024 - 16:33 MDT
This incident affected: Pax8 Platform (Pax8 Platform).