Order Provisioning Delay
Incident Report for Pax8 Platform
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 15:38 MDT
Identified
Due to an issue with an upstream provider, the provisioning of new and updated orders is currently delayed within the Pax8 Platform. Orders can still be submitted, but provisioning may not be completed until later today.

We will continue to post updates on this page. We appreciate your patience while we work on resolving this issue.
Posted Jun 13, 2023 - 13:59 MDT
This incident affected: Pax8 Platform (Subscriptions).