Invoice Delay
Incident Report for Pax8 Platform
Resolved
All invoices have been sent. This has been resolved.
Posted Apr 07, 2023 - 10:59 MDT
Update
Invoices are being sent out. We appreciate everyone's patience in this matter! We will update this status as resolved once all invoices are sent.
Posted Apr 06, 2023 - 14:46 MDT
Monitoring
Due to the recent outage, invoices have been delayed. We are working diligently to provide these as soon as possible. Please check back here at status.pax8.com for updates.
Posted Apr 06, 2023 - 12:00 MDT
This incident affected: Pax8 Platform (Billing).