Provisioning Task Outage
Incident Report for Pax8 Platform
Resolved
Our order backlog has been caught up and new orders should be processing as expected. Please review our blog post on the Microsoft NCE update for further information: https://www.pax8.com/blog/microsoft-csp-new-commerce-experience/
Posted Mar 03, 2022 - 17:14 MST
Update
Due to high Microsoft NCE order volume some users may experience delays in license delivery. Our development and support teams are currently aware of this issue and are actively working on improving performance.

We apologize for the inconvenience and appreciate your understanding while working to correct the issue.
Posted Mar 02, 2022 - 11:48 MST
Monitoring
Our provisioning backlog has stabilized and we are continuing to monitor for any further slow down in service.
Posted Mar 01, 2022 - 08:17 MST
Identified
Our teams are still working on improving our performance and catching up on our backlog of provisioning.

We have a few messages to convey in this update:

1. If customers are performing a change of channel, in order to avoid any interruption in service, we ask that they do not place cancellations until the new subscriptions through Pax8 are available in their tenants.

2. If the legacy to NCE 'Upgrade' workflow is followed, there is no risk of service interruption.

3. If an order has been placed and it's not going through, please do not place a quantity update to try and make it go through faster. This may place your account in an inconsistent state.
Posted Feb 28, 2022 - 14:17 MST
Update
Our system is still experiencing heavy delays in order processing. We continue to make changes which are improving our performance, however, we have a large queue to catch up on. Our current estimates are ~12hours behind on provisioning.
Posted Feb 28, 2022 - 11:13 MST
Investigating
Our provisioning tasks are experiencing a service outage that has resulted in temporary service delays.

We are investigating the root cause, and our team is working diligently to resolve the issues.

We apologize for the inconvenience and appreciate your understanding while working to correct the issue.
Posted Feb 28, 2022 - 08:56 MST
This incident affected: Pax8 Platform (Catalog).